Verification is currently underway. A small number of users have run into login issues related to stale cache. Here's the fix:
Mac: 1. Open Terminal (press Cmd + Space, type "Terminal", hit Enter) 2. Paste this and press Enter: dscacheutil -flushcache && sudo killall -HUP mDNSResponder 3. It will ask for your Mac password - type it (it won't show characters as you type) and press Enter
Windows: 1. Press Windows key, type "cmd", right-click Command Prompt and choose Run as administrator 2. Paste this and press Enter: ipconfig /flushdns
Posted Jul 11, 2026 - 16:32 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 11, 2026 - 15:00 EDT
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Jul 08, 2026 - 14:14 EDT
This scheduled maintenance affected: Management Portal and API.