Several integrations degraded by AWS incident

Incident Report for Kroo

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:13 PDT

Monitoring

We're continuing to monitor AWS status pages as systems are showing recovered performance
Posted Oct 20, 2025 - 11:28 PDT

Update

We are continuing to monitor this issue as some systems become available.
Posted Oct 20, 2025 - 09:54 PDT

Update

We are continuing to monitor this issue.
Posted Oct 20, 2025 - 09:34 PDT

Identified

Our team is continuing to monitor the status of the AWS status page
Posted Oct 20, 2025 - 07:26 PDT

Investigating

Due to the ongoing AWS outage, users may experience delayed data syncs. Our team is continuing to monitor the status and closely monitoring the AWS status page: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 06:43 PDT
This incident affected: Management Portal and Data Processing.